Ruby 2.4.0 リファレンスマニュアル > ライブラリ一覧 > 組み込みライブラリ > NotImplementedErrorクラス

class NotImplementedError

クラスの継承リスト: NotImplementedError < ScriptError < Exception < Object < Kernel < BasicObject

要約

現在のプラットフォームで実装されていない機能が呼び出されたときに発生します。

例えばfsyncやforkのシステムコールに依存するメソッドが呼び出されたとき、OSまたはRubyの実行環境がそれらのシステムコールをサポートしていない場合、この例外が発生します。

forkがNotImplementedErrorを発生させる場合respond_to?(:fork)はfalseを返すことに注意してください。

目次